[Coldstuff] Method meta-data

Bruce Mitchener bruce@cubik.org
Mon, 07 Jan 2002 07:39:39 -0700


xmath wrote:

>> You don't have an accessor to return all of the meta data for a single 
>> method
> 
> I've now made all accessors public, and only do the sanity-checks if the 
> caller() wasn't root (otherwise I'd have to make separate +access=root 
> and +access=pub versions: one without and one with checks)
> 
> (note I check against #0 instead of $root, because that's what Genesis 
> does too)


Except #0 is $sys, not $root.  Please just use the objnames and not 
objnums.  Nothing in ColdCore should be directly referring to an object 
number.

> and I think I've addressed all the other issues too.
> 
> new version again at:
> http://www.nubz.org/method_meta.cold.txt

A couple of things still:

Why is the method help returning, not throwing ~keynf?  Errors should 
always be thrown.

Spell out field and don't just use fld in the method names.

I'd still rather see the underlying variable called method_metadata 
rather than just method_meta.  There are other meanings for meta that 
could confuse the issue and the longer form is much less ambiguous.

$root.defines_method() should probably just be what it claims:  return 
method in (.methods());

In $root.set_method_flags(), could you rename current and drvr to be 
current_flags and driver_fags?  That would increase the readability 
there as well.

There are some other uses of this as well by the way that might be good 
to supply default implementations for:

  * Copyright info
  * Last-modified data/time/by whom
  * 'Currently being edited' (with some sort of timestamp so it can
    be expired.)

  - Bruce