[376] in Coldmud discussion meeting

root meeting help first first in chain previous in chain previous next next in chain last in chain last

Re: objname vs dbref

daemon@ATHENA.MIT.EDU (Mon Jul 11 06:24:03 1994 )

From: stewarta@netcom.com (Alex Stewart)
To: deforest@netcom.com (Robert de Forest)
Date: Mon, 11 Jul 1994 03:19:16 -0700 (PDT)
Cc: coldstuff@MIT.EDU
In-Reply-To: <199407110746.AAA19747@netcom12.netcom.com> from "Robert de Forest" at Jul 11, 94 00:46:53 am

> I did in fact request that the routines which manipulate the object lookup
>  table refer to the lookup keys as names. That is, I prefer add_objname to
>  set_name. In the current docs, $foo is a name expression which evaluates
>  identically to get_name('foo).

I really don't get your logic here, I guess..  seems to me you're saying these
things should be called objnames because get_name calls them names, even though
you admit that get_name isn't a good name for it anyway..

>  $foo therefore, is not really a dbref, since
>  it has the name layer between 'foo and the actual number of the object.

Umm.. so you're saying $foo isn't a dbref because it isn't a object number
(which is exactly what distinguishes a dbref from an objnum in the first
place)?  I guess I just don't understand what you're trying to say.

Anyway, on to the real point:

What I proposed at the beginning of this whole thing and what I thought
everbody more or less agreed on was the use of dbref and _dbnum_, which in my
opinion makes perfect sense.  I suppose we could change it to objref and
objnum, but that doesn't sound as nice to me.  I really would prefer that we
not use the term "name" in any of it for clarity reasons (haven't we been
through all this several times before?).  I can still see myself trying to
explain to people that when I say "object name" I mean something completely
different than when I say the logical abbreviation "objname"..  sigh.

As I've said before, I see no reason why the $foo syntax shouldn't be called a
dbref.  It is, quite simply, the way database objects are referenced
("db"-"ref") by anything outside server internals (i.e. by the real world).
Likewise I don't see why we can't call the numbers dbnums, appropriately.  The
consistent alternatives to using objnum, however, both have problems, to my
mind, which is why I suggested dbnum to begin with.

   Alex Stewart - stewarta@netcom.com - Richelieu @ Diversity University MOO