[576] in Coldmud discussion meeting

root meeting help first first in chain previous in chain previous next next in chain last in chain last

Re: Assignment Operator.

daemon@ATHENA.MIT.EDU (Thu Nov 10 19:19:03 1994 )

From: Alex Stewart <riche@crl.com>
To: jcdst10+@pitt.edu (James C Deikun)
Date: Thu, 10 Nov 1994 16:13:35 -0800 (PST)
Cc: rayn@crossaccess.com, coldstuff@MIT.EDU
In-Reply-To: <Pine.3.89.9411091518.A2325-0100000@unixs2.cis.pitt.edu> from "James C Deikun" at Nov 9, 94 04:00:22 pm

[something that was asked a while back that as far as I know was never

> I do not have a full understanding of what exactly a tick is however.
> Would someone clairify this for me?

1 tick basically corresponds to one cycle through the internal opcode
interpreter in the server (i.e. execution of one opcode of compiled ColdC).
Since different operations perform different tasks of varying complexity, and
since actually doing the tasks involved can be faster or slower depending on
the machine, ticks therefore say very little about how much processing effort
or time is really used.  All it really says is how far through the execution of
the method things have progressed.

Now, as for the issue at hand..

Actually, I only proposed := when we were discussing assignment-expressions in
the first place.  If we don't have assignment expressions, I really don't see
that it matters much one way or the other, and don't really see why we should
bother changing it anyway..

> Yes.  The is the only reason I personally support := is that I support
> assignment as an expression.  However, I'd much rather have .= or '= for
> assignment--much MUCH easier on the pinkies.

Ugh.  I don't like '.='.. for one thing, part of the reason I liked := as
an alternative was that colon isn't currently used for anything else in the
language anyway.  '.=' is not only different from anything anyone's ever seen
(at least most people recognize := from pascal and so can guess at what it
means), but it's also somewhat potentially confusing, as both '.' and '=' mean
things already and '.' is a significantly different type of operation than the
process '.=' would have anything to do with..  As far as easier typing, if we
go with your suggestion below, you wouldn't have to use it much unless you
wanted to anyway ('=' is easier to type than even '.=' anyway)..

> What I'd like to see is:
>   =  as an assignment statement, as it is now.
>   .= as an assignment expression.
>   == as a comparison expression.

This idea is also one I proposed some time ago in the assignment-expresion
debate (using := instead of .=, of course).. as I remember nobody really said
much about it.  By this time, I'm rather of the position that if any changes
are made they should be along these lines or we should just leave everything
the way it is..  [note that this is essentially the same thing that Colin was
proposing, with the addition of non-confusable assignment-expressions as part
of the change]

     Alex Stewart - riche@crl.com - Richelieu @ Diversity University MOO