[675] in Coldmud discussion meeting

root meeting help first first in chain previous in chain previous next last

Re: more comments

daemon@ATHENA.MIT.EDU (Thu Mar 9 12:03:20 1995 )

From: The Importance of Being Chuck <cadams@weather.Brockport.EDU>
To: crag@serial.mit.edu (Robert de Forest)
Date: Thu, 9 Mar 1995 11:56:59 -0500 (EST)
Cc: coldstuff@MIT.EDU
In-Reply-To: <m0rmQyw-000KcEC@serial> from "Robert de Forest" at Mar 8, 95 01:01:13 pm

Robert de Forest drew these heiroglyphs:

> With all that said I pick <- with no reason other than taste and the fact that
>  it can't be read as 'equals' (and that it makes for a nice flow thing for
>  chained assignments).

I'll just bind it to a single key in my term program anyway.  
'<-' looks cool.

> Private or Local methods: I would like to see a distinct way of calling local
>  methods to give us the performance boost. Jordan used :foo() in his version
>  but I don't like that because of MOO. What about foo()? The compiler can
>  generate a local method call rather than a builtin function call if the
>  identifier isn't a valid builtin.

how about ->foo()?
Of course, that makes it confusing with respect to the `<-' operator.

I personally have no problem with `:' and I am a hard-core MOO junkie.
But if that's too impalatable, how about ..foo()?  I personally would
find that very difficult to read, and would prefer the dots stacked
instead of side-by-side.