[691] in Coldmud discussion meeting

root meeting help first previous next next in chain last in chain last

continuing the debates

daemon@ATHENA.MIT.EDU (Fri Mar 10 14:16:30 1995 )

From: crag@serial.MIT.EDU (Robert de Forest )
To: coldstuff@MIT.EDU
Date: Fri, 10 Mar 1995 13:11:04 -0600 (CST)

I am glad someone came up with add_method as an alternative to whatever I said.
 I also like the idea of coldc_to_method and method_to_coldc. Do we really want
 to split out the parts of a program tho? Would it be better to have add_method
 take args of method_id, falgs, args, vars, body as opposed to placing the
 last four args inside the structure for a method? The disassemble function,
 I'll call it get_method, will need to return something and it seems most
 rational to have it return whatever add_method takes as its arg. If I have
 it return a list you can splice it (@), but Brandon pointed out that a dict
 makes more sense.

I'm just nit picking and stuff. For now add_method will take two args. The name
 and structure. (add_method('foo, #[['flags, []]...]))

I will have default values for all elements of the dictionary, too. #[] will be
 a valid program. :)

-----

I do not like :-, nothing about it says assignment to me.

On the other hand, when I'm done with method_to_coldc and coldc_to_method I
 may be able to enhance those functions by providing a way to supply different
 strings for operators and functions. HAHAHAHAHA. I have no idea how to do
 that in coldc_to_method. OH well.

I guess that's all for now.

Crag