[771] in Coldmud discussion meeting

root meeting help first first in chain previous in chain previous next next in chain last in chain last

Re: fork() vs send()

daemon@ATHENA.MIT.EDU (Sat Aug 19 14:20:39 1995 )

Date: Sat, 19 Aug 1995 12:19:13 -0600
From: 869683 Gillespie Brandon James <brandon@avon.declab.usu.edu>
To: coldstuff@MIT.EDU

< 1. Call it something different.  send() just doesn't say 'fork'.

Actually, it seem's my impression of what send() was suggested as, is wrong.
They were suggesting send() as an in-db looping speedup, so you could replace:

  for obj in (object_list) {


  send(object_list, method, args);

He did suggest that fork could be hidden behind send, but I dont think he
was suggesting it as a complete replacement for fork.

One of the main reasons I like(d?) it better than a direct fork() 
implementation is because it _is_ cleaner.

< 2. An argument for a delay time ala fork (n)

Hmm, I dunno... I would like to add the delay times to pause(), with the
default of no args meaning a 0 second pause (just pop me at the back of
the current task list).  If you forked off, and wanted a delay, just call
pause() afterwards...