[974] in Coldmud discussion meeting

root meeting help first previous next next in chain last in chain last

[COLD] controlling object of a task (user()/controller()/etc)

daemon@ATHENA.MIT.EDU (Tue Apr 23 19:52:22 1996 )

Date: Tue, 23 Apr 1996 17:22:20 -0600 (MDT)
From: Brandon Gillespie <brandon@tombstone.sunrem.com>
To: coldstuff@cold.org

Ok, it sounds like the general concept is accepted (assuming this since 
everybody I talked to and those on the list instantly jumped to syntax :)

Frankly I would rather use 'user()' because it is short, it is not always 
conceptually correct--which is also a large drawback for me.  The two goals
I have with naming it are: ease of use (I really dont like long function 
names in high-use positions) and appropriateness.  Since I plan on 
evolving ColdC more and more to handle more tasks, I'd like to keep 
appropriateness in mind.  Anybody have a thesarus?  :)  Suggestions on 
the table:

     controller()      -- most appropriate, too bulky and long

(I forget any others...)

I'm actually liking 'client()' or 'server()' (both are appropriate, 
depending upon the point of view you are taking).