[975] in Coldmud discussion meeting

root meeting help first first in chain previous in chain previous next next in chain last in chain last

Re: [COLD] controlling object of a task (user()/controller()/etc)

daemon@ATHENA.MIT.EDU (Tue Apr 23 20:42:22 1996 )

Date: Tue, 23 Apr 1996 17:04:18 -0700 (PDT)
From: No one of any consequence <seanl@beef.bovine.com>
To: Brandon Gillespie <brandon@tombstone.sunrem.com>
cc: coldstuff@cold.org
In-Reply-To: <Pine.BSF.3.91.960423171421.11050A-100000@tombstone.sunrem.com>

I vote for client(), since it's short, and since the client is typically 
the end making the request, it seems appropriate to me.

On Tue, 23 Apr 1996, Brandon Gillespie wrote:

> Ok, it sounds like the general concept is accepted (assuming this since 
> everybody I talked to and those on the list instantly jumped to syntax :)
> Frankly I would rather use 'user()' because it is short, it is not always 
> conceptually correct--which is also a large drawback for me.  The two goals
> I have with naming it are: ease of use (I really dont like long function 
> names in high-use positions) and appropriateness.  Since I plan on 
> evolving ColdC more and more to handle more tasks, I'd like to keep 
> appropriateness in mind.  Anybody have a thesarus?  :)  Suggestions on 
> the table:
>      controller()      -- most appropriate, too bulky and long
>      server()
>      con()
>      user()
>      requestor()
>      client()
> (I forget any others...)
> I'm actually liking 'client()' or 'server()' (both are appropriate, 
> depending upon the point of view you are taking).